RHEL – Update-Problem

RHEL und andere auf RHEL-basierende Linux-Distributionen zeigen seit ca. Mitte August 2021 folgenden (oder einen ähnlich lautenden) Update-Fehler, wenn Docker darauf installiert wurde:

 

Fehler:
Problem: package containers-common-1:1.3.1-5.0.1.module+el8.4.0+20289+730b73cc. x86_64 requires runc, but none of the providers can be installed
– package containerd.io-1.4.9-3.1.el8.x86_64 conflicts with runc provided by r unc-1.0.0-54.rc5.dev.git2abd837.module+el8+5201+6423ecab.x86_64
– package containerd.io-1.4.9-3.1.el8.x86_64 obsoletes runc provided by runc-1 .0.0-54.rc5.dev.git2abd837.module+el8+5201+6423ecab.x86_64
– package containerd.io-1.4.9-3.1.el8.x86_64 conflicts with runc provided by r unc-1.0.0-55.rc5.dev.git2abd837.module+el8.0.0+5215+77f672ad.x86_64
– package containerd.io-1.4.9-3.1.el8.x86_64 obsoletes runc provided by runc-1 .0.0-55.rc5.dev.git2abd837.module+el8.0.0+5215+77f672ad.x86_64
– package containerd.io-1.4.9-3.1.el8.x86_64 conflicts with runc provided by r unc-1.0.0-55.rc5.dev.git2abd837.module+el8.0.0.z+5239+bd2c200f.x86_64
– package containerd.io-1.4.9-3.1.el8.x86_64 obsoletes runc provided by runc-1 .0.0-55.rc5.dev.git2abd837.module+el8.0.0.z+5239+bd2c200f.x86_64
– package containerd.io-1.4.9-3.1.el8.x86_64 conflicts with runc provided by r unc-1.0.0-56.rc8.dev.git425e105.module+el8.0.0+5336+de35ffea.x86_64
– package containerd.io-1.4.9-3.1.el8.x86_64 obsoletes runc provided by runc-1 .0.0-56.rc8.dev.git425e105.module+el8.0.0+5336+de35ffea.x86_64
– package containerd.io-1.4.9-3.1.el8.x86_64 conflicts with runc provided by r unc-1.0.0-60.rc8.module+el8.1.0+5440+994fc847.x86_64
– package containerd.io-1.4.9-3.1.el8.x86_64 obsoletes runc provided by runc-1 .0.0-60.rc8.module+el8.1.0+5440+994fc847.x86_64
– package containerd.io-1.4.9-3.1.el8.x86_64 conflicts with runc provided by r unc-1.0.0-61.rc8.module+el8.1.0+5460+5d763c32.x86_64
– package containerd.io-1.4.9-3.1.el8.x86_64 obsoletes runc provided by runc-1 .0.0-61.rc8.module+el8.1.0+5460+5d763c32.x86_64
– package containerd.io-1.4.9-3.1.el8.x86_64 conflicts with runc provided by r unc-1.0.0-64.rc9.module+el8.1.1+5502+fbec5cc6.x86_64
– package containerd.io-1.4.9-3.1.el8.x86_64 obsoletes runc provided by runc-1 .0.0-64.rc9.module+el8.1.1+5502+fbec5cc6.x86_64
– package containerd.io-1.4.9-3.1.el8.x86_64 conflicts with runc provided by r unc-1.0.0-65.rc10.module+el8.2.0+5584+b2b2d3fb.x86_64
– package containerd.io-1.4.9-3.1.el8.x86_64 obsoletes runc provided by runc-1 .0.0-65.rc10.module+el8.2.0+5584+b2b2d3fb.x86_64
– package containerd.io-1.4.9-3.1.el8.x86_64 conflicts with runc provided by r unc-1.0.0-65.rc10.module+el8.2.0+7615+180dc822.x86_64
– package containerd.io-1.4.9-3.1.el8.x86_64 obsoletes runc provided by runc-1 .0.0-65.rc10.module+el8.2.0+7615+180dc822.x86_64
– package containerd.io-1.4.9-3.1.el8.x86_64 conflicts with runc provided by r unc-1.0.0-66.rc10.module+el8.2.1+7658+86e51d52.x86_64
– package containerd.io-1.4.9-3.1.el8.x86_64 obsoletes runc provided by runc-1 .0.0-66.rc10.module+el8.2.1+7658+86e51d52.x86_64
– package containerd.io-1.4.9-3.1.el8.x86_64 conflicts with runc provided by r unc-1.0.0-68.rc92.module+el8.3.0+7866+f387f528.x86_64
– package containerd.io-1.4.9-3.1.el8.x86_64 obsoletes runc provided by runc-1 .0.0-68.rc92.module+el8.3.0+7866+f387f528.x86_64
– package containerd.io-1.4.9-3.1.el8.x86_64 conflicts with runc provided by r unc-1.0.0-70.rc92.module+el8.3.1+9659+c1901784.x86_64
– package containerd.io-1.4.9-3.1.el8.x86_64 obsoletes runc provided by runc-1 .0.0-70.rc92.module+el8.3.1+9659+c1901784.x86_64
– package containerd.io-1.4.9-3.1.el8.x86_64 conflicts with runc provided by r unc-1.0.0-70.rc92.module+el8.4.0+20157+b6591bfb.x86_64
– package containerd.io-1.4.9-3.1.el8.x86_64 obsoletes runc provided by runc-1 .0.0-70.rc92.module+el8.4.0+20157+b6591bfb.x86_64
– package containerd.io-1.4.9-3.1.el8.x86_64 conflicts with runc provided by r unc-1.0.0-73.rc93.module+el8.4.0+20195+0a4a4953.x86_64
– package containerd.io-1.4.9-3.1.el8.x86_64 obsoletes runc provided by runc-1 .0.0-73.rc93.module+el8.4.0+20195+0a4a4953.x86_64
– package containerd.io-1.4.9-3.1.el8.x86_64 conflicts with runc provided by r unc-1.0.0-74.rc95.module+el8.4.0+20289+730b73cc.x86_64
– package containerd.io-1.4.9-3.1.el8.x86_64 obsoletes runc provided by runc-1 .0.0-74.rc95.module+el8.4.0+20289+730b73cc.x86_64
– cannot install the best update candidate for package containers-common-1:1.2 .0-9.0.1.module+el8.3.1+9659+c1901784.x86_64
– cannot install the best update candidate for package containerd.io-1.4.4-3.1 .el8.x86_64
– package runc-1.0.0-55.rc5.dev.git2abd837.module+el8+5190+20ee9d65.x86_64 is filtered out by modular filtering
– package runc-1.0.0-55.rc5.dev.git2abd837.module+el8.0.0+5214+b7869c3a.x86_64 is filtered out by modular filtering
– package runc-1.0.0-55.rc5.dev.git2abd837.module+el8.0.0+5337+91623acb.x86_64 is filtered out by modular filtering
– package runc-1.0.0-55.rc5.dev.git2abd837.module+el8.1.0+5440+42cffa37.x86_64 is filtered out by modular filtering
– package runc-1.0.0-56.rc5.dev.git2abd837.module+el8.1.0+5459+24f6812a.x86_64 is filtered out by modular filtering
– package runc-1.0.0-56.rc5.dev.git2abd837.module+el8.2.0+7621+b33f33e5.x86_64 is filtered out by modular filtering
– package runc-1.0.0-56.rc5.dev.git2abd837.module+el8.3.0+20164+d105d709.x86_6 4 is filtered out by modular filtering
– package runc-1.0.0-56.rc5.dev.git2abd837.module+el8.3.0+7864+d0e2eddf.x86_64 is filtered out by modular filtering
– package runc-1.0.0-56.rc5.dev.git2abd837.module+el8.3.0+9668+293abd4d.x86_64 is filtered out by modular filtering
– package runc-1.0.0-64.rc10.module+el8.2.0+5585+88100286.x86_64 is filtered o ut by modular filtering
– package runc-1.0.0-64.rc10.module+el8.2.0+7618+3a616245.x86_64 is filtered o ut by modular filtering
– package runc-1.0.0-64.rc10.module+el8.3.0+7863+c7f8774f.x86_64 is filtered o ut by modular filtering
– package runc-1.0.0-64.rc10.module+el8.3.0+9619+9eeb6ed6.x86_64 is filtered o ut by modular filtering
– package runc-1.0.0-64.rc10.module+el8.3.0+9660+5fcec09e.x86_64 is filtered o ut by modular filtering
– package runc-1.0.0-64.rc10.module+el8.3.0+9670+b9fad87d.x86_64 is filtered o ut by modular filtering
– package runc-1.0.0-64.rc10.module+el8.4.0+20172+38c78bba.x86_64 is filtered out by modular filtering
– package runc-1.0.0-65.rc10.module+el8.4.0+20187+0135169c.x86_64 is filtered out by modular filtering
– package runc-1.0.0-70.rc92.module+el8.4.0+20156+89a24d29.x86_64 is filtered out by modular filtering
– package runc-1.0.0-71.rc92.module+el8.4.0+20196+91e9c2ae.x86_64 is filtered out by modular filtering

 

Der Fehler wird durch das Paket „containers-common“ (hier in Version: 1:1.3.1-5.0.1.module+el8.4.0+20289+730b73cc. x86_64) hervorgerufen.
In einer Docker-Umgebung wird dieses Paket nicht benötigt und kann mit dem Befehl:

sudo dnf remove containers-common*

entfernt werden. Danach ist ein Update des Systems wie gewohnt möglich!

In einer Umgebung in der mittels Podman, Buildah… (also der RHEL-eigenen Containervirtualisierung) gearbeitet wird, sollte kein Fehler auftreten.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht.